Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5101-
PBM-MN and Siemens S7-300

PROFIBUS Configuration for Moxa MGate 5101-PBM-MN
and Siemens S7-300

Moxa Technical Support Team

support@moxa.com
Contents
3 TN I3 o o Yo [T o oY o TN 2
2. Applicable productS.....ccccveiirrsrsra s s s s s s s s s s r s rrrrararnnranan 2
3. System requiremMeENnts ..ciciiorrarer s s s s r s r s r s rr s ra s rrrarnrnrnnnnnanE 2
4, SYStemM OVEeIVI@W .iicciiciiiciiiemisesrassras s srassrassrasssasssasssasssssssssssnsssnnsanssanssnnsnnnnss 2
5. PLC configuration ....cciiiciiiiimimsmsmssmss s smsssmssssssssssssasssasssasssasssanssnnssnnnnns 3
5.1.  Create STEP 7 ProjJeCt .uiviiiiiiiiiiiiiii i s s s e s nnnaaaas 3
5.2. Create a virtual PROFIBUS Master deVICE ...iviviiiiiiiiiiiiniiiiiisiiinsrsriinnsiineens 4
5.3. Create@ PROFIBUS NEEWOIK .uuviutiiiitisiieiiineeraeesssintessnnreransessnnesssnnessanneeens 7
5.4. Create PROFIBUS SIaVe AeVIiCe. . iiiitiiiiiii it i it s rineeraaeeranaeeenneess 10
5.5, Create I/O MOAUIES. . .iii ittt it e e st si e e e s s saaareeerinns 12
6. Moxa’s PROFIBUS device configuration.......c.cceciimiisinsimssiesnmsnnsesnnnnsass 15
T A 1 o 13 or= || o TN C 1 0 1 15
6.2. Device configuration with MGate Manager..........ccoiiiiiiiiiiiiicciie e 16
7. Communication TesSt....iicciuiiiririrassrs s ssra s ara s srs s aran s asasssasanssnnnnssnannnnnnns 19
7.1, Create Variable Table...coviii i e e 19
7.2.  Modify and monitor I/O data ....coooiiiiiii i e 21
Copyright © 2013 Moxa Inc Released on May 1, 2013
About Moxa

Moxa manufactures one of the world’s leading brands of device networking solutions. Products include serial
boards, USB-to-serial hubs, media converters, device servers, embedded computers, Ethernet I/0 servers,
terminal servers, Modbus gateways, industrial switches, and Ethernet-to-fiber converters. Our products are key
components of many networking applications, including industrial automation, manufacturing, POS, and medical
treatment facilities.

How to Contact Moxa

Tel:  +886-2-8919-1230 Web: www.moxa.com MOXA

Fax: +886-2-8919-1231 Email: info@moxa.com



mailto:support@moxa.com

Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5101-
PBM-MN and Siemens S7-300

1. Introduction

This application note describes the configuration of Moxa MGate device as a
PROFIBUS DP master to connect to a Siemens S7-300 PLC as a PROFIBUS DP slave.
One word input and one word output data are configured in this example.

2. Applicable products

Product Line Model Name

MGate 5000 series MGate 5101-PBM-MN, MGate 5101I-PBM-MN,

MGate 5101-PBM-MN-T, MGate 51011-PBM-MN-T

3. System requirements

Description
Siemens S7-300 PLC

Siemens PLC programming software

Moxa PROFIBUS DP master to Modbus TCP
gateway
GSD file for Siemens S7-300 DP slave

Software utility to configure Moxa device
Modbus TCP master software

4. System overview

Model / File Name

CPU 315-2 PN/DP
Article Number:
6ES7315-2EH14-0ABO
SIMATIC STEP 7

MGate 5101-PBM-MN

SIEM8180.GSE
MGate Manager
Modbus Poll

Version
3.2.3

5.5 + SP2
1.0

13
1.6
3.60a

In this document, MGate 5101-PBM-MN is used as an example. The system architecture

is shown below.
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PC
(Modbus TCP master

Ethernet ‘

(Modbus TCP slave)
Mgate 5101-PBM-MN
(PROFIBUS master)

I PROFIBUS DP

(PROFIBUS slave)
Siemens S7-300 PLC
CPU 315-2 PN/DP

5. PLC configuration

5.1. Create STEP 7 project

5.1.1. Start SIMATIC Manager and create a new project by selecting File > New.
The user must assign a name for this project. In this example, we use

“Demol” as the project name.

KJSIMATIC Manager

File PLC View Options Window Help

Mew Project’ Wizand .. !

Open...

Ctl+0

37 Memory Cand
Memorr Card File

b
b

Copyright © 2013 Moxa Inc.

Page 3 of 23




Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5101-
PBM-MN and Siemens S7-300

New Project x|

User projects | Libraries | Multiprojects |

Hame | Storage path

% 37 Pl CAProgram FiledGiemens@tep e Tpof'd ¥ _Fro
%37-300_]:'1)_31&\?8 CWProgram Files\SiemensStep 7T profS7- 300,
%S?—SDD_meibusSl&ve CAProgram FiledGiemens@tep e T poofia - 200,

4] |
Tuwpe:
Project -
[~ FLibrazy
Storage location (path):
IC:\ngIam Files\RiemensStep v proj Brovwse... |
Cosl | __Eep |

g

5.2. Create a virtual PROFIBUS master device
5.2.1. Select Insert - Station > 2 SIMATIC 300 Station to insert a SIMATIC
300 Station, which means the Siemens S7-300 PLC in this project.

{; SIMATIC Manager - Demol

File Edit | Ineet PLC  Wiew Opton: Window Help
Statinn 1 BIMATIC 400 Station

Snbnet Ll 2 EIMATIC 300 3tation
Program P ZEIMATIC H Station
I , 4 SIMATIC.PC & tation
7 Block , 5 Other Station
e , 6 SIMATIC 35

T PGPC
sambol Table
Tt Lahrams L
Erdernal Bomrce.

Name the SIMATIC 300 Station “Virtual_Master” and double-click it to
perform more configurations.

K JSIMATIC Manager - Demol

File Edit Insert PLC  Wiew Options  Window Help
O 8765 | % B din || @ 2g| %0 B
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5.2.2. Double-click the Hardware icon and the HW Config window will appear:

FIJ;HW Config - [Wirtual_Master (Configuration) -- Demo1] =13 x|
@l Sttion Edit Insit PLC View Options Window Help = x|

0288 88| e b B |8
ﬂ oixl

Suchen: I ﬁﬂ: i

Brofile  [Standard =l

288 PROFIEUS Pi
=38 PROFINET IO

< |
:I !l Virtoal Master
Slot | Designation
I

- SIMATIC 400
- SIMATIC BC Based Control 300400
-8 SIMATIC PC Station
[FROFIEUS-DP shaves for SIMATIC 57, M7, and C7 (istdbuted i<|
rack) =

Press Fl fo get Help | ,_ 4

Drag the Rail item located under SIMATIC 300 > RACK-300 (in the
hardware catalog window on the right) to the upper half of the Station
window on the left:

FIJ;HW Config - [Virtual_Master (Configuration) -- Demo1] =101 x|
@) Station Edit Insert PLC View Options Window Help 1= x|

0288 8 &) =6 da B |8
ﬂ ol

Buchen: I ﬁﬂ: i

Profile  [Standard =l

38 PROFIEUS P4
=38 PROFINET IO

4 |

:I !l Virtoal Master
Slot | Designation
I
-8, SIMATIC FC Station
[PROFIEUS-DP slaves for SIMATIC 57, M7, and C7 (distibuted EI
cack) i
Press Fl to get Help | 4

An empty grid will then appear in the upper half of the Station window as
shown below:
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EEHW Config - [Firlnal_Master (Configuration) -- Demol]

=10] x|
@l Stetion Edit Inset PLC View Options Window Help =] x|
[0S E-B 88| e b BB
ﬂ EE
Suchen: | .nﬂ: i
Brofile  [Sandard =l
-39 PROFIEUS DP
28 PROFIEUS Pa
-3¢ PROFINET IO
- SIMATIC 300
<
|0
Slot Module Order number Firmware | WP address Ia..
1
2
3
4
T o0 SIMATIC 400
£ - SIMATIC PC Based Control 300400
7 08 SIMATIC PC Station
g
g
10 GEST 300-17770-0440 ¢
11 \Available fn various lengths —
Insertion possble | | Chg 2

5.2.3. You must add the proper version firmware for the CPU module hardware
model. In the figure below, we use CPU 315-2 PN/DP as an example. Drag
the proper version of the CPU module firmware from the Hardware Catalog
window on the right and drop it into the empty grid in the Station window on

the left.
FIJ;HW Config - [¥irtual_Master (Configuration) -- Demol] =10 x|
@) Station Edit Insert PLC View Options Window Help 1= x|
0288 8 &) 6e da BE |8
2l ol
Buchen: I “ﬂ: i
Brofile  [Standard =
-] CPU 313C-2 DP A

4|

o

{21 CPU 314C-2 DF
{1 CPU 314C-2 PN/DP
{20 CPU 314C-2 PP
{3 cPU 315

{21 CPU 315-2 DP

Shot Module Order nuimber Firmware | MPLaddeess | ILa.. CPU 215-2 FNDP

1 {1 6ES7 315-2EG10-04B0

5 N {1 6ES7 315-2EH13-04B0

3 " {1 BES7 315-2EH14-04B0

4 :

5

g ——

= {10 CPU 315F-2 EN/DE

F] acrss

El - CPU 315-2 DF =

10 [BEST 315-2EH14-0ABD - {<|

11 1284 KB work memory; 0.05ms/1000 instouctions; PROFINET i
iconnection; 37 Communication (oadable FBsFCs);
PROFINET I0-Contmller; support: RTRT; FROFINET [

Press F1 1o get Help | | Chz 2

You will then be prompted to enter the proper IP address for the CPU module:
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Properties - Ethernet interface PN-I0 (RO/52.2) ﬂ

Genersl  Parameters |

If & subnet iz selected,
the next available addresses are sugpested .

Crafewany
{* Do not vz mooter
~ Use router
[ Use different method to abtain IP address Address I
Subnet:

--- not networked ---

Cowd | Hep |

Then the related blocks will be automatically added to the grid as shown

below:
E-E_:HW Config - [Virtnal Master (Configuration) - Demol]
E“] Station Edit Insest PLC  View Options Window Help

D288 & S| =0 da %8 W

& CPU 315-2 PN/DP

eslow

3ot I Module Order number Firmware | MPI address Ta..
1

2 CPU 315-2 PH/DP 6EST 315-2EH14-0AB0 V32 2

AY MEROF 2 2047
Az FiLe) 245
Az Foue { 2045
Az Fore 2 ZddT

5.3. Create PROFIBUS network
5.3.1. Double-click on the MPI/DP field to open the Properties - MPI/DP
window to configure the PROFIBUS DP module. Set the interface type to
PROFIBUS by selecting PROFIBUS from the Interface - Type dropdown

menu.
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x
General | Addresses | Opersting Mode | Configwstion | Clock |
Fhort Description: MFLTE
=l
[]
Name: |MPI.*DP
Wetwarked: Tes Froperties. .. |
Comment:
=l
[ -]
Cancel |  Hep |

Assign the address for PROFIBUS master module under the Parameters tab
and click the New... button to create a new subnet.

Properties - FROFIBUS interface MFPI/DF (RD/S2 1) x|

General  Parameters |

If & subnet iz selected, the next
available address iz sugpested .

--- not networked ---

Cowd | Hep |

5.3.2. Select the proper transmission rate for this subnet. After completing these

modifications, click the OK button to return to the Properties - MPI/DP -
(RO/S2.1) window.
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Properties - FROFIBUS interface MFPI/DF (RD/S2 1) x|

General  Parameters |

Address: IE vl

Highest address: 126

Transmizdon rate; 1.5 Mbps

Subnet:

PROFIBUR(1) 1.5 Mbps

Switch to the Operating Mode tab and set the mode as DP master.

Properties - MPL/DP - (RO52.1) ﬂ

(reneral | Addresses Operating Mode | Contiguration | Clock |

= NoDE
= DP slave
[~ Test, cormmissoning, muting
Iaster: S tation
Fadule
Eack (B fslot (3)
Eeceptacle for interfane module
Diagnostic addess; I
Address for "slat" 2 |
Cowd | By |

You should then see the results shown in the following figure, indicating that
the PROFIBUS network was created successfully.
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FIJ-:{:HW Config - [Firtnal Master (Configuration) -- Demol]
ﬁ“| Btaton Edit Insert PLC View Opton: Window Help

DS 8 B & ke dda e %8 ke

B PROFIBUE(L): D master systern (13

5.3.3. Close the HW Config window and return to the main window of the "Demo1”
project.

5.4. Create PROFIBUS slave device
5.4.1. Follow Step 5.2 to create a PROFIBUS slave device and name it "DP_Slave.”

K JSIMATIC Manager - Demol

File Edit Insrt PLC  Wiew Optons Window Help

D@ |85 | $ e |dn|lo % 2| 8=

|| < Mo Fitter - =7 |

B Demol -- C:\Program Files\Siemens\Step7is7proj\Demol

& [ DP_Slave
[ Virtual_Master

5.4.2. Double-click on DP_Slave > Hardware to open the HW Config window.
Repeat steps 5.2.2 to 5.2.3 to add the proper CPU module to the PROFIBUS
slave device.

5.4.3. Double-click on the MPI/DP field and the Properties - MPI/DP window
will appear for you to configure the PROFIBUS DP module. Set the interface

type to PROFIBUS.
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x
General | Addresses | Opersting Mode | Configwstion | Clock |
Fhort Description: MFLTE
=l
[]
Name: |MPI.*DP
Wetwarked: Tes Froperties. .. |
Comment:
=l
[ -]
Cancel |  Hep |

5.4.4. Select PROFIBUS(1) to connect it to the subnet created in Step 5.3.2. Then
click the OK button to return to the Properties - MPI/DP - (R0/S2.1)
window.

Properties - PROFIBUS interface MPI/DF (RO/S2 1) ﬂ

Genersl  Parameters |

Address: |3 vI If o subnet iz selected, the next
available address iz suggested.
Highest address: 126

Tranzmizion rate: 1.5 Mhbps

Enbiet:

5.4.5. Select the Operating Mode tab and set the mode to DP slave.
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Froperties - MFI/DE - (ROfSZ.1)

Genersl | Addresses Opersting Mode | Configurstion | Clock |

x|

= o DE
" DP master

e DP dlave
[~ Test, comumdsdoning, ronting

Master: Station

Module

Rack (B} f slot (3)
Diagnostic address: |2043
Address for "slot" 2: |2042

Cancel

Help

5.5. Create I/0O modules

5.5.1. Next, create the I/O modules you would like to add to the S7-300. In the
following example, we will use the internal I/O modules for illustration

purposes.

5.5.2. Follow step 5.4.5, select the Configuration tab and select Word from the
Unit dropdown menu for both Input and Output I/O modules.

Froperties - MFI/DE - (ROfSZ.1) x|
General | Addresses | Operating Mode Configuration IClock i
Row | Mode | Partner DF ad... | Partneraddr. | Localaddr. | Length | Consisten... |
1
4
Blew Hdit.. [elete
Eomrent: I ﬂ
Comel | oty |
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Properties - MPI/DP - (R0/S2 1) - Configuration - Row 1 =l
IMode: IMS vl (Master-slave configuration)
—DP Partner: Master —————— —Local: Blave
P address: I vl DF address: |3 I assizmment: -
aime: ] Name: [MRIDE od address: I
S ilress fype: I vl Address type: IInput vl tifimd] e |
L dress: l— Address: ID—
"Elot": l— "Slot"™: l—
Process tmage: I vl Process image: IOBI TI vl
Intermipt OE: I o i Diagnostic address: I
Length: I 1 Comment:
[~
Consiztency: it - LI
ok | hmb | Comeel |  Help |
Properties - MPI/DP - (R0fE2.1) - Configuration - Row 2 5'
Iode: IMS vl (M aster-slave configuration)
—DP Partner: Magter ————— —Local: 8lave
P address: I vl DP addres: |3 Mod assignment: -
Neme: — Name: [MFIDE Ko address: |
A dress type: I = i Address type: IOutput - l ad yame: I
Ll diress: l— Address: ID—
“Elat"; l— "Slot™: l—
Erocess fmage: I vl Process tmage: IOBI Tl vl
Intermpt OE: I - I Diagnostic addres: |
Length: | 1 Comment:
-
Consistency: Tnit v LI
ok | sy | Concel | Hep |

After adding the above I/O modules, you will see the following
configurations:
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Froperties - MFI/DE - (ROfSZ.1) x|

Genersl | Addresses | Opersting Mode Configwstion | Clock |

Fow | Mode | Parbuer DF ad... | Partner addr. | Local addr. Length Consisten. ..
1 ME - - I 1 o

il

s

Blew ... Edit. . Dielete
— M3 Master-glave configuration
Master:
Btation:

Comrgnt: I ﬂ
ok | Cancel |  Help |

5.5.3. All the configurations are now ready. Choose Station > Save and Compile
to save and compile the settings for the Siemens S7-300.

EJL-,I:HW Config - [DP_Slave {(Configuration) - Demol]

Sation it Tnsert iew Options ow  Help
Edit I PLC Wi Opti Tlind, Hel
J C Wew... Chl+N

=l

Open... Chl+O ===
Cpen ONLINE

Cloz=
Bave
Save and Compile

Properties. .

Impoit... J
Export... |

5.5.4. Select PLC - Download from the menu bar to download all the settings to
the Siemens S7-300.

Copyright © 2013 Moxa Inc. Page 14 of 23




Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5101-
PBM-MN and Siemens S7-300

K JSIMATIC Manager - Demol

File Edit Insert | PLC  WView Option: Window Help
Acces Rights

EDemol - C

Carnpile and Dowiload Objects...
plaad to PG

Upload Station to PG

Copy Bk to ROM..

Download User Program to kemory Card

Save to Memory Card ...
Retrieve from Memorr Card...

6. Moxa’s PROFIBUS device configuration

6.1. Install the GSD file
Before configuring the Moxa MGate 5101-PBM-MN, install the GSD file for the
PROFIBUS slave device so the MGate 5101-PBM-MN can recognize the device.

6.1.1. Execute MGate Manager and click the GSD Management button to install

the GSD file.
Na. | MName | Madel | MAC Address
01 MGate 5101_229 MGate 5101-PEM-MM 00:90:E8:00:01

Device Identification Device Function

Search Configuration

Lacate Laad efault

Language G50 Management

Click the Add button to locate the GSD file.

G5D Management ﬂ
Mame | Vendor | Filename

QK |

4| | i

Copyright © 2013 Moxa Inc. Page 15 of 23
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Select the GSD file and click the Open button to install it.
(@open

o A 3 N
9\ )= | .~ Work ~ Siemens_57-300 & I Search Siemens_57-300
Organize *  Mew folder E==
- N )
‘¢ Favorites =1 Name | Date modified | Type
Bl Desktop . SIEM8180.GSE 3/10/2010 1:24 PM
& Downloads || SIEM3180.G5F 3/10/2010 1:26 PM GSF File
1=l Recent Pl
4 Recent rlaces || SIEMB8180.G5G 8/10/2009 9:25 AM G5G File
- . . || SIEM8180.GSI 3/10/2010 1:28 PM G5 File
.l Libraries
3 Documents || SIEM3180.G55 3/10/2010 1:29 PM G55 File
J“. Music
= Pictures
EE videos
18 Computer
&, 1308471008 (C:)
e Removable Disk (07
5 TS (\\moxa.com'mt
([ | 2
File name: [SIEMB180.GSE [

Open |v| Cancel |

6.2. Device configuration with MGate Manager
6.2.1. Start MGate Manager and Search for the Moxa MGate 5101-PBM-MN.

! MGate Manager

Mo, | Mame | Model | MAC Address

Device Identification Device Function

Configuration

Locate | Load Default

6.2.2. Select the target device and click the Configuration button to configure it.
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IS el

Device Identification Device Function

Search | Monitor | Fro@am Mapping | Import |
Locate | Load Default | Diagnose | Upgrade Firmware Export |

Language GSD Management | OffLine Configuration

6.2.3. Select the PROFIBUS tab and click the PROFIBUS Settings button to start
PROFIBUS configurations.

x
OK I
= Cancel
Modbus/TCP
5101-PEM-MN
| 1 PROFIBUS
¢ 1 i
w0) \ - I; I
‘f (
Basic I Metwork PROFIBUS IModhus' Systeml
Address | Type | MName | endor
1 Master | Moxa PROFIBUS Master Moxa Inc.

I PROFIBUS Settings I

6.2.4. Select PROFIBUS - AutoScan or click the AutoScan button to enable the
AutoScan function to scan the network for the PROFIBUS slave device
automatically.
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Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5101-
PBM-MN and Siemens S7-300

PROFIBUS Settn
——

Fil Edit | PROFIBUS
= Fle Edit PROFIBUS

~

PROFIBUS DP

|

[

or

6.2.5. The MGate 5101-PBM-MN will find the PROFIBUS slave device as shown

below:
Devices connected to the network
l_ | Device status | Addr... | Ident... | Model name | Vendor | Module | G5D file |
Master in bus configuration 1 0x0DF3  Moxa PROFIBU...  Moxa Inc. - MPEMODF 3.gsd
O  slave notin bus configuration 3 0x5180 | CPU 315-2PN/... | SIEMENS 1st general ID SIEM3180.G5E

1st general ID

1st general ID
Master_Q Slave...
Master_I Slave...

Based on the settings of Siemens S7-300, modify the “general ID” to:

1st general ID
2nd general ID

3rd general ID
Select the checkbox as shown in the following screenshot:

Devices connected to the network

I | Device status | Addr... I Ident... | Model name | Vendor | Module | GSD file |
Master in bus configuration 1 0xODF3 | Moxa PROFIBU...  Moxa Inc. MPBMODF 3. gsd

0x5180 | CPU 315-2PN/... | SIEMENS 1st general ID SIEMB180.G5E
2nd general ID
3rd general ID
Master_Q Slave...
Master_I Slave...

Slave notin bus configuration 3

Then click OK button and the MGate 5101-PBM-MN will finish the

configuration for you.

6.2.6. After verifying all the settings, click File > Save to save the configuration
and click File > Exit to exit the PROFIBUS Settings window.
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-i0ix]

Fle Edit PROFIBUS
F=
Ll
- || PROFIBUS DP = _
= Pragrammable Logic Col (1)Moxa PROFII

E1-[10 SEEMENS

B ] cPu315-2PNT —_—
- 1st general

- 2nd genera
- 3rd general
- Master 15k
- Master 15k
[ Master_I 5l m
- Master 15k
- Master 15k s
[ Master 18k "Common 1/0Data |G"’UD properties | User parameter
- Master_13) -
- Master_13)
- Master_13)
- Master_13)
- Master_13)

- Master_I 5k
- Master_I 5k

- Master_I5l o
4 | »]

(3)CPU 315-2P)

Module
1st general ID
0x00 2nd general ID

0x00 Srd general ID

Ox60 Master_Q) Slave_I 1Wo unit 0.1 a
0x50 Master_I Slave_Q 1Wounit 2.3

Quiput address
0x00

R AR TR

e

6.2.7. On the main window, click the OK button to save the changes and the MGate
5101-PBM-MN will reboot for the changes to take effect.

x
= Cancel

Modbus/TCP

7. Communication Test

7.1. Create Variable Table
To monitor the internal memory of the Siemens S7-300, add a Variable Table to
modify or monitor the I/O modules we have created.
7.1.1. Return to the Step 7 in project “"Demo1” and click DP_Slave > CPU 315-2
PN/DP. You will then be able to select Insert > S7 Block - Variable
Tables from the menu bar to add a Variable Table.

KJSIMATIC Manager - Demol
File Edit | Ineert PLC  View Optione Window Help

O || Setion Mlialle % EEE
Bibmet e
s Pm ’ £ 1 [ P [) 1 . [0
E--% D Z71 57 Programi3) qu:unnﬁciiuns

o E A7 Software L4
= 27 Block 1 Qrpanization Block

M7 Bottware e 2 Function Block
ER 7 3 Function
Sambol Table
Text Lib . 4 Data Block

5 Data Tvpe

e S
o 6 Variable Table
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(Here, we use the default name VAT_1 for the Variable Table.)

7.1.2. After creating the Variable Table, double-click on the VAT_1 icon to configure
which I/O module to monitor.

K JSIMATIC Manager - Demol

File Edit Insert PLC Wiew Options Window Help

D (8% | & R o2 25 % |n 8 = | & |[<NoFer>

DP_Slave
-[@ cPU 3152 PHIDP

7.1.3. Enter the address we configured into the Address column:
=

Table Edit Imsert PLC Varable View Options Window Help
4| D[\ @] &|wle]of| x| =8| K| lsr]«] 8] sl

2| 8d3ess| Symbol| Display foomat| Status value | Modify value

J L

Press Fl for help [ © [ifme  |shs<sz |
For this example:

IWO for the Input module has a length of 1 word.
QWO for the Output module has a length 1 word.

¥AT_1 -- Demo1\DP_Slave\CPU 315-2 PN/DPAS7 Program

A b ddess Symbol | Dhsplay forrmat| Btatus value | Diodify walue
1 W 0 HEX
2 QoW 0 HEX
3

7.1.4. Click the Monitor button to start monitoring.
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3l Var - VAT 1 -[of x|
Table Edit Insert PLC  Wariable Wiew Option: Window Help
*| Dl & (@0~ x| =8| K|

]

x| Bddiess | Bymbol | Display fornat| Btadus ralue Modify value
I[ T 0 HEX WRLGRI000
z| QW 0 HEX WA WHER]
3

Demol\DP_Slavel. . \87 Programi3) @ .;I &

7.2. Modify and monitor I/0 data

7.2.1. Execute the Modbus Poll function on the PC to simulate data exchange from
the Modbus TCP master to the MGate 5101-PBM-MN.

7'c Modbusz Foll - [Mbpolll] 10| =l
File Connection Setop Functions Display  View  Window Help ;l
Bl x|

ODSE&S|x |58 &0 05 06 15 16 22 23| 101]
Tx = 1le2: Exr = 0: ID = 1: F = 03: 3R = 1000m=

40001 = 0x0000
40002 = 0x0000

For Help, presz F1. For Edit, double click on a value. 192168351 »

7.2.2. The first test is to write data to the Input module of the PROFIBUS slave.
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Table Edit Insrt PLC Vamsble WView Ophons Window Help

| DIl & ¢l x| [F 8 K| ofer o a4

- . Modbus Poll - [Mbpolll] =]

Fde Connection  Setup  Functions  Display  View  Window Help ;I
=1
ODOEE&| %[5 |5 2| L 05 0815 16 22 23 | 101

Write Single Register

40002 = 0

pdws |1

Value (HEZ): | 1111

¢ 06: Write single ve gister
(" 16: Write multiple registers

’—Use Funetion

Demol'\DP_Rlaveh.. \27 Program(3) @ - i

The Input module of the PROFIBUS slave device is updated by the Modbus
Poll’'s command from 0x0000 to Ox1111.

For Help, press F1. For Edit, double click on a valve 192.168.35.1. ~

A Var- VAT 1 M=(ES| [ . Modbus Poll - [Mbpolll] -1ol x|
Table Edit Insert PLC Variable View Options Window Help ] File Conngction Setup  Functions Display View Window Help =

| Dl &l & (mlE]ol~| x| el W] e v & 2

: DEEE| X|F|=S &1 050615 16 22 23| 101]
o VAT 1 -- @D 11DFP_Slave CPU 315-2
EPRENE TP . Single Zat TN jpooes

40002 = Oz
Address |1 Cancel
alue (HEE): |1111
Tse Function
& 06: Write single e gister
= 16: Write multiple registers

Demn1\DP_Slaveh 7 Program(3) 4> [RUN /| For Help, press FL. For Edit, double click an a value [CAEEAW

7.2.3. The next test is to read data from the Output module of the PROFIBUS slave.
1ol =lolx|

Table Edit Insert PLC Verable View Options Window Help [*d File Connection Setip Fuonctions Display  View  Window Help —|
o 5 far =1

| Dl=ld| & %||Eﬂn|“|ﬂ|§ﬂﬁ|‘ Sfer | 54 DEES&|x |2 & 005 0615 16 22 23 | 1]

[BLVAT_I _ @Demol\DF_Slave\CPU 315-2 PN/DFST Prog . |0 x| e Er — 0 - T =5 = ooos

£ dddmes | tyerbal | Display faorrat| Status value

1 JE] HEX
40002 = 0x0000

2 ow 0 HEX
3

Demol'\DP_Rlaveh.. \27 Program(3) For Help, press F1. For Edit, double click on a valve 192.168.35.1. ~

The value of address 40002 is updated by the Output module of the
PROFIBUS slave device from 0x0000 to 0x9999.
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€3] Var - VAT 1

Table Edit Insrt PLC Vamsble View Opbons Window Help

~=lol x|

- . Modbus Poll - [Mbpolll] =]

| DIl & ¢l x| [F 8 K| ofer o a4

Fde Connection  Setup  Functions  Display  View  Window Help ;I

&
: DEES&|x |2 & 005 0615 16 22 23 | 1]
% FAT 1 - @Demol\DP_Slave'\CPU 315-2 PH/DPST Prog . |0 x| . = 2051 Esr = 0: ID = 11 F = 03: SR = Lo00ms
£ dddmes | tyerbal | Display faorrat| Status value Madify value
I w o HEX WHEHILL
z| QW0 HEX Wileieses [ ISR

Demol'\DP_Rlaveh.. \27 Program(3)

For Help, press F1. For Edit, double click on a valve

192.168.35.1. ~
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