INL1000PLUS| Series driver debugging
software instructions
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1 the software introduction and description

1.1 the Software introduction

The operating environment of the software is Windows 7 and Windows 10
operating system. It is suitable for NL100OPLUS series inverters, used to debug
inverters, easy to modify parameters, and oscilloscope function to check the bus
voltage, output current and other parameters.

1.2 the Software function description

Open the folder where the software is located in [Inverter1.0.1], which
contains two folders and [InverterP.exe] software. The Data folder stores data,
and the Lst folder stores configuration files and images used in the program.

» Inverterl.01 » v @
=
=2 EEE:
Data 2019/9/12 13:549
Lst 20191172 14:42
ﬂ InverterP.exe 2019/10/28 0:30

1) Open the [InverterP.exe] software main interface as follows:

% Converter Parameter Modification -V1.0.1

<«=—— Upper navigation bar

Tnverter | <@mmm=———— | oft navigation bar

serial send 24 serial receive 23 serial overtime 0

2) Top navigation bar function preview:
In [Edit], there are [serial port setup], [device management]|, [Desktop display



label], and [Exit].
In [Window], there are [Layout], [display Left frame], [fault Information].
In [Help],there are [About] and [Help].

Edit Window Help

serial port setup Window = Help

device management Layout Help
Desktop display label display Left frame About
Exit fualt infomation Help

—

Preview on the left navigation bar, the left navigation bar can perform
real-time monitoring, view parameter list, import parameters, operate keyboard,
oscilloscope, and fault record. The function is as follows:

v Inverter 1
~real data

- Param list

- import param
- pdate param
~oscllloscope
- fault data

2 Detailed description of each function

2.1 Device connection

Use the 485 serial cable to connect the device, the device is connected to the
RS+ and RS- ports, and the other end is connected to the computer via USB.

2.2 Edit

2.2.1 When using the software for the first time, you need to open the [serial port
setup] and modify the serial port number. If you do not know the serial port
number, you can view it in [My Computer] -> [Device Manager] -> [Port (COM
and LPT)]. After confirming the port, modify it in the software and click [Open]. If
the button is displayed as [Off], you need to click twice.



Port Baud |'E|EIDC| v|| O | . X

[ show receive data. overtime (m=) 20 .
ave
[Jzend not interval. zet time(ms)
U show zend data Clear receives [ Zero
[]5end Dec | Send
MCRC chet =t

Use the lower left display to determine if the connection is successful. When the
connection is successful, the serial send and serial receive are increasing.The
connection is fail if serial overtime is increasing.
serial send 5 serial receive 0 serial overtime 4

2.2.2 Select a matching device type

Switch the device type in [Edit] -> [device management]. You can also modify
the device name here. After the modification is completed, click the [Modify]
button to save. After modifying the device type, you need to restart the software.

device management x>
device name |Inverter | Umove the locati pgeq display button
Nodbus Add |1 | | gif position Odisplay REV
Left: 117 O di el =
device type NL10Q0FPLIOS w display F_
| |
MEnable this device Height: [120 [Jdisplay P_F¥
Width: 100 [ free stop

display gif |n|:| show animatior v|

Modify the zif to be show path in Lst/animat(1l. . &) zif

add update delete next debug window

After completing the above settings and modifications, you can use the
software to view the parameters, compare the actual values with the default
values, and modify the parameter values.



2.3 Window

2.3.1 Modify layout

Click [Window] -> [Layout], you can place the background image you want to
switch in the folder Lst, and fill in the name of the picture in the layout window.
You can also modify the desktop background color and switch between Chinese
and English. After editing, click Save. After saving, you need to restart the
software to implement the modification.

2 Layout seting >
Desktop Backzround Pictured|BE. jpgl Mpicture stretch
Desktop Background Color E2@, ~
[IMaximize the main Desktop b Show English

save
[move the location of pictures and display label

2.3.2 Click [Window] -> [display Left frame] to hide/show the left navigation bar.
2.3.3 Click [Window] -> [fault information] to check whether the inverter is
currently faulty. If it is faulty, display the fault information.

2.4 Help

2.4.1 If there are any problems during the use, you can click [Help] -> [About] to
call the software service.

about )4
i

Converter Parameter Modification

inverter monitoring software

service phone 13452339880

2.4.2 Click [Help] -> [Help] to view the applicable environment and usage of the
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software.

Help

Nperating envirorment:Windows 7, Windows 10 operating system.

Commection steps:
Step 1 Cormect the serial port.
Step 2 Add the device and select the device type.

Change the interface picture, save the picture under Lst
BE. ipz, replace it

Eeplace the application name: open SysSet. dl]l file with
Hotepad, modify the name of Comparny="Y{YiXY¥¥¥ compary’

The current wersion 1.0.1, lastest time 20159-05-11.You can
contact our company staff to get the latest wersion.

1. Support wvarious types of inwverters (requires modify
database files).

2. Support serial port MODEBUS ETU protocol.

3. Support meonltoring of multiple units and multiple
inverters. That 1s to support the use of one computer to
monitor multiple and multiple inverters at the same time.
4. Support function code parameter uplead and download,
parameter file import and export.

2.5 Left navigation bar function

2.5.1 View real-time parameters

The display is as follows:




Irwverter Addr=1 X

EealTime name Value FealTime name Value
Operating freque 0. 00 Bushar voltage 226, 6
Output voltage 12,50 Cutput current 0.0

o output flag Qoo o000 Current temperature 0

Eotating speed 0 Cumalative running - 375
FIV1 data =10, 00 FIVZ =10, 000
FIV3 =10, 000 software wersion 0

FWD Etop | reset

adjustnent '(szI Set [

current state Stop

You can modify the displayed real-time parameters, double-click the
parameter name, and set the parameters that the user needs to display. As shown
in the figure below, refer to the manual to change the title name, receive address,
and decimal places displayed.

update monitor parameter x

A RA -l -l nerating fregquency

receive address |0, 0x7000=0 ~

display dot 2 Save

2.5.2 View param list

You can select the parameter group, or click the left and right buttons to view
the parameters of the adjacent parameter group. red indicates that the current
value of the parameter does not match the default value.



F# Update parameter Inverter device type:PH300E Address=1 x

| << ||D1 0il pump parameter view vl 2 Find OutputData edit database
F.Code ParameterMame Value Unit Default MNax Hin Property
D1. 00 Motor anzle 234.9 ° 0 3509.9 0.0 7
D101 0il pressure setting 0.0 Kz 0 Syatem oil press 0.0 i
D1. 02 0il pressure feedback walus 0.0 Kz 0 System oil press 0.0 it
D1. 03 Motor running speed 0 rpm 0 30000 -599 ¥
D1. 04 FIV1 analoz woltage 0.0 v 0 10.0 -10.0 i
D1.05 FIVY analog woltage .o V 0 10,0 -10.0 ¥
D1. 06 FIC analog woltage 0 v 0 10 -10 ¥
D1. 07 FIV] simulation zero drift O v 0 10 -10 e
D1. 08 FIVZ similation zero drift O V ] 10 -10 T
D1.09 FIC simulation zero drift 0 W 0 10 -10 e
D110 Given flow corresponding fre 0.0 Hz 0 Naximum frequenc 0.0 i
D111 The degree of disturbance o: 0 0 1000 0 +r
D1. 12 Communication oll pressure « 0.0 Eg 0 System oil press 0.0 7
D1. 13 CAN commmication interferer 0 n 128 0 e
[1. 14 CAN send number ] ] B5635 0 i
D1. 15 Number of CAN receptions 0 0 G535 0 ¥
DL.16  CAN buffer usage 0 % 0 Lo 0 e

The parameter value can be modified by clicking on the current value of the
parameter. The modification takes effect after closing the window for modifying
the parameters.

Operation panel Inverter device type:PH300E Address=1 x
F. Code P2. 00 (KK >
param valueA’ 2 modifiable

Nax: 65545 Nin: 0 edit database

Fermanent magnet synchronous servo motor

Motor type default : model dependent



Click [edit database] to modify the parameters of the parameters and modify
the default values, units, maximum values, and minimum values. Click [Refresh]
after modification.

P update database recard pot

add delete update L4 g reflash

Func. CoP0. 00 | Address Clt=itl =55 |t}fpe display |

default|factn:ur}r cn:urre| Tnit Max: Nin:

Detailllesc: Property |H£$ﬂ$ﬁ|?f{ v|

1: Heavy load type

2.5.3 Import param

When you need to modify multiple parameters at the same time, you can
organize the parameters into a txt file. Place the file in the Data folder, click [open
file], and select the file you want to import. After importing, click [execute].

P $EIETRRE SN Inverter device type:PH300E Address=1 Bl &8s ot X
Interval (ms) execute open file

Address Name Commarid Value
FOUZ Operation command channel selection 06 noo1

Foo3s Frequency source superposition selection 06 nooz

Foo4d Main frequency sowrce x selection 06 oooz

Foos fuxiliary freguency source v selectlion 06 noog

F500 FVD terminal function selection (6 ool

FEO1 EEV terminal function selection ]3] 0004

F502 sl terminal function selection 06 a00s

File template description:




| s e —Sins - 0EE - O b
MR wEE B0 E'N) EEH)
[SYs] :
ModeType=PH300 <mmm— Inverter type
Date=2019-11-05 13:09:18 <e—— import time
[Record]
Operation command channel selection=06F0020001 E
Frequency source superposition selection=06F0030002
Main frequency source x selection=06F0040002
Auxiliary frequency source y selection=06F0050008
IFWD terminal function selection=06F5000001
REV terminal function selection=06F501000A
S1 terminal function selection=06F5020008
S2 terminal function selection=06F5030012
S4 terminal function selection=06F5040025
PID given source=06FA000005

Command format:

PID feedback source=06FA020001 PID intial value=06FA150140
PID given feedback range=06FA042710 PID intial Value--param name
Proportional gam=O6FA05G05A/ 06--write command

PID initial value=06FA150140 )
PID initial value holding time=06FA1607D0  FA15--operation on PA.15

0140--write value 140

Windows (CRLF)  Z 147, £ 17 100%

2.5.4 update param

Simulate keyboard operation, select or fill in the function code, fill in the
value to be modified in the parameter value box, click the [Modify Parameter]
button, the modification is completed, and the modification will take effect after
the window is closed.



Operation panel Inverter device type:PH300E Address=1
Switch function code left and nght

Max:

F. Code

param value k] 2

P2. 00

LS8 b

modifiable

65535

Nin:

Update param value

0

edit database

Fermanent magnet synchronous servo motor

Motor type

2.5.5 oscilloscope

Select the parameters and gains to be displayed. A maximum of four
parameters can be displayed. Click CH1, CH2, CH3, and CH4 to select the channel
for recording. Modify the unit length, sampling interval, trigger channel, and
trigger value of the x axis as required. Then click [Start], and the parameter
change will start to be displayed in the coordinate axis. Select the curve by frame
to enlarge the curve. Select [Cursor] to draw two vertical scales in the picture or
switch to horizontal scales. The scale difference is displayed on each channel.

Click [Stop] torecord gain.

10
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CHL CH2 CH3 [T cra X axis |1
03TV 0.00 Hz 2.418 7

Trigger chammel m
Trigzer valus
[bus voltage [=][output frequency [~][Speed referencs Flx|joutput current || Apogine 404 vertical

molingInterval

cH1 CHZ CH3
893.7 ¥ 0.00 Hz 2.419 ¥
mpling Interval

[bus woltage [~]joutput frequency [~ |[speed reference F[x |[output current Ay=2

: -

[T cH4 ¥ axiz |1 Trigger channel

T v

[

level

2.5.6 fault data

You can view the fault log, read the current fault of the drive, and clear all
faults.

11



P8 fault query X

Clear fault fault find

MO deviceMame fault inf State Time display PBun Hz Current Valtage Input terminal State Time N Eun Time Type

3 Troubleshooting

If the debugging software fails, reconnect the serial cable to the computer. If
it still does not work properly, open [Monitor Serial Port] in [Settings].
[# Converter Parameter Modification

Edit Window Help

| serial port setup

device management
Desktop display label
Exit

I ™

Check the display serial.port to send data, view the data sent and received,
and find out the solution to the problem.

Port [CON5  v|Baud ([9600 || off @ | X

[Jshow receive data.overtime (ms) :2':' | &
: . Save
B send not interval.set time(ms) 1200
[ show send data Cleax receives 2109 Zexo
ISend 01 03 80 00 00 01 AD CA
Send 01 03 T0 00 00 13 1E C7
Send 01 03 70 08 00 01 1F 08
Send 01 03 70 00 00 13 1E C7
Send 01 03 70 00 00 13 1E C7
Send 01 03 T0 00 00 13 1E C7
Send 01 03 70 00 00 13 1E C7
Send 01 03 70 00 00 13 1E C7
Send 01 03 70 00 00 13 1E C7
Send 01 03 70 00 00 13 1E C7
[Jsend De | -
FACRC che | |

12



4 Connect new devices

To connect to a new series, you need to switch the device type in [Edit] ->
[device management], click [Add] then restart the software.

device management ®

device name |Inverter ‘ Umave the locati pypei e gailewy D

Nodbus Add |1 || eif position [ display REV
Lot |

device type Ldisplay F_RE
Top: 514

M Enable this|[PH300E Height: [Jdisplay P_F¥
Width: |100 [l free stop

display =if |no show animatior -

Modify the gif to be show path in Lst/animatfl. .6} zif

add update delete next debuz window

5 Others

If you can't solve the problem, please contact the supplier or manufacturer
for processing, or call the software service phone in [Help]->[About]. Thank you!
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